CELO Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jan 13, 2023 - 17:54 CET
Investigating
We have detected a problem with getting latest blockchain data from CELO Explorer. We are checking this incident.
Posted Jan 13, 2023 - 17:50 CET
This incident affected: Ledger Explorers (Celo (CELO)).