BCH explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Feb 21, 2021 - 17:14 CET
Investigating
BCH explorer API test has failures detected. We are checking this incident.
Posted Feb 21, 2021 - 17:12 CET
This incident affected: Ledger Explorers (Bitcoin Cash (BCH)).