VTC Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 23, 2022 - 22:00 CET
Investigating
We have detected a problem with getting latest blockchain data from VTC Explorer. We are checking this incident.
Posted Nov 23, 2022 - 21:50 CET
This incident affected: Ledger Explorers (Vertcoin (VTC)).