"Explorer DOGE" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jan 29, 2021 - 17:57 CET
Investigating
Error code HTTP 503 - Service Unavailable
Posted Jan 29, 2021 - 17:51 CET
This incident affected: Ledger Explorers (Dogecoin (DOGE)).